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SOME GENERAL REMARKS 

What is a “partitur”?  
“Partitur” is the German word for a musical score. In linguistics, it is used to describe a particular way to 
layout transcriptions of spoken language: Just like in a musical score where the music to be performed by 
each voice or instrument is written on a separate staff, different speakers or different modalities are tran-
scribed on different lines of a linguistic partitur:  
 

 
 
In that way, it becomes possible to represent simultaneity which is very frequent in spoken language, for 
instance when (as in the above example) speaker turns overlap or when (as in the following example) 
utterances are accompanied by gestures or mimics.  
 

 
 
A partitur is also useful for integrating analytical or other additional information into the transcription. 
Thus, in the following example, English translations are simply added on a separate line beneath the cor-
responding French utterances:  
 

 
 
To learn more about partitur notation, have a look at Ehlich (1992), Edwards (1992) or Schmidt (2002), 
(see bibliography at the end of this manual). 
 

Why use the Partitur Editor and not a word processor? 
The Partitur Editor is a software tool for inputting and outputting transcriptions of spoken language in par-
titur notation. Compared to an ordinary word processor, it facilitates this task because it allows editing 
(i. e. changing, deleting, adding etc.) at an arbitrary place in the partitur without having to bother about 
breaking up the text so that it fits on a page of a certain size. When you input data into the Partitur Editor, 
you do this into one single partitur of (potentially) infinite width:  
 

 
 
Only when you output the partitur (e. g. to a printer or a RTF-file) does the software “chop up” this large 
partitur into several smaller partiturs that fit on a given page size:  
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What is special about the EXMARaLDA Partitur Editor? 
EXMARaLDA is an acronym of EXtensible MARkup Language for Discourse Annotation. It is an XML-
based system for encoding transcriptions of spoken language in a computer-readable way. Because it is 
XML based and because it makes use of the annotation graph formalism proposed by Bird/Liberman 
(2001), EXMARaLDA transcriptions are more easily exchangeable between different programs and be-
tween different platforms and they are more flexibly adaptable to other purposes than transcriptions in 
other storage formats are. In other words: the Partitur Editor is not just meant to be an instrument for in-
putting and outputting partiturs, but it is intended as one of several input and output tools for EXMAR-
aLDA data. You can, for instance, use Praat or a text editor to make a raw transcription, then import this 
data into the Partitur Editor, print out a partitur, and then export it to the Atlas Interchange Format (AIF) 
for archiving. 
 
Furthermore, as the partitur editor is being programmed in Java, you can use it on different platforms, i. e. 
on Windows, Macintosh or Linux.  
 
 
 
HOW TO USE THE PARTITUR EDITOR: A SHORT TUTORIAL 
The graphical user interface of the Partitur Editor consists of a main window and some auxiliary panels. 
The main window contains the menu bar, several toolbars and the partitur itself. The partitur is divided 
into several tiers where each tier has a label and comprises several events. These events are aligned 
with one another and with the events in other tiers by the help of a timeline. Working with the Partitur Edi-
tor therefore means manipulating tiers, tier labels, events and the timeline:  
 

  

main window 

partitur 
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menu bar

tool bar 

timeline 

tiers 

vertical 
scrollbar 

horizontal 
scrollbar 

eventstiers labels 

time intervals 

 
 
Keyboard 
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Link panel 
 

 
 

   
 
 
Audio/Video panel 
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Praat panel 
 

 
 
Segmentation panel 
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1. Create and edit a transcription in the Partitur Editor  

Step 1 – Create a new empty transcription 
If you haven’t just started the editor (and therefore have a new empty transcription in front of you, any-
way), choose File > New. The partitur should then look like this:  
 

 
 
 

Step 2 – Edit the meta information 
Choose File > Meta information...  Enter a project name, a transcription name etc. into the text fields pro-
vided. In order to add a user defined attribute, click on Add attribute... and enter the desired attribute 
name. The corresponding value goes into the other cell of the respective table row:  
 

 
 
Close the dialog by clicking on OK (otherwise, the changes will not be retained). 
 
 

Step 3 – Edit the speaker table 
Choose File > Speakertable... . Select the existing speaker (X) and change the corresponding Abbrevia-
tion. Edit this speaker’s properties. To add user defined attributes, proceed as in step 2.  
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Add another speaker by clicking on Add speaker. Select this new speaker and change the corresponding 
properties. In order to add the user defined attributes of the first speaker, click Collect attributes. Close 
the dialog by clicking on OK (otherwise, the changes will not be retained).  
 
The partitur should now show the modified speaker abbreviation:  
 

 
 
 

Step 4 – Create tiers  
Choose Tier > Add tier... . You will be shown a dialog in which you can specify properties of the new tier. 
Choose a speaker and a type (a verbal tier will usually have type “T”, a non-verbal one type “D” and an 
annotation type “A”) and enter a category (e. g. “v” for “verbal”).  
 

 
 
Close the dialog by clicking OK. Repeat this step until the partitur has as many tiers as you need. (You 
can, of course, add more tiers later if necessary). The partitur should then look something like this:  
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Depending on their type, the tiers are assigned a standard formatting. You can change this at any time 
(see further down).  
 
 

Step 5 – Transcribe  

You can now transcribe by entering text into the cells. The size of the cells will automatically adapt to the 
size of their content.  
 

 
 
Keep in mind, that, according to the EXMARaLDA paradigm, transcribing means  
 describing events,  
 assign them to a speaker and a category  
 and place them on a timeline. 

 
You assign a speaker and a category by choosing the corresponding tier. Placing the event in time is 
done by locating the appropriate time interval, i. e. the corresponding cell beneath the appropriate section 
of the timeline. The actual description is done by entering text into this cell.  
 
For the above example, this means there are altogether five events.  

1. The event described by “Du fällst mir immer” is assigned to speaker “Max”, to the category “v” and 
to the time interval 0.  

2. The event described by “gestikuliert” is assigned to speaker “Max”, to the category “nv” and to the 
time intervals 0 and 1.  

3. The event described by “ja gar nicht.” is assigned to speaker “Tom”, to the category “v” and to the 
time interval 2.  

4. /5. Since the events described by “ins Wort” and “Stimmt” are simultaneous, they are assigned to the 
same interval (interval 1), in other words: the two speakers’ contributions overlap at this place etc.  

 
The editor has several methods to support entering and editing such events. You’ll find these methods in 
the menus “Event” and “Timeline”.  
 
 

Step 6 – Save transcription 

Choose File > Save as… and use the dialog to give name to the file (the suffix “.xml“ is generated auto-
maticly) and to save it. 
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2. Format a transcription  
Formatting, i. e. information about fonts, font sizes, background colors etc. is not part of the transcription 
itself, but treated as additional information which is only relevant for visually representing a transcription in 
the editor or in the output. Formatting information is therefore stored separately from the transcription 
data (as a separate file). The editor assigns a default formatting to each tier. This section shows how you 
can modify this default formatting according to your needs.  
 
The architecture of the system only allows formatting a tier as well as the tier labels or the time line labels 
as a whole. It is not possible to format a certain segment of a tier (e. g. a single word or utterance) in bold 
type, italics or in a different font. If you’d like to use different formats only for aesthetical reasons you can 
design the transcription later on as an exported RTF document. If a certain format is part of the transcrip-
tion convention you follow (e. g. representing emphasis by underline), try to think of an alternative way of 
characterizing it. 
 

Step 1 – Format a tier 
Create a new transcription or open an existing one. Tiers and labels will be given a default format by the 
editor. Select the tier whose format you wish to change by clicking on the corresponding tier label:  
 

 
 
Now choose Format > Format tier... (or use the corresponding symbol of the toolbar or die keyboard com-
bination Strg+F using a PC respectively ⌘ +F using a Macintosh). You will be given a dialog in which you 
can change the formatting properties. For instance, you can change the font, the font size or the back-
ground color. The “Test area” works as a kind of preview and lets you test your changes.  
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Close the dialog by clicking on OK (otherwise, the changes will not be retained). The selected tier will now 
have the modified formatting:  
 

 
 
 

Step 2 – Alternative 1: Format tier and timeline labels  
In order to change the formatting of tier labels or timeline labels choose Format > Format tier labels... 
respectively Format > Format timeline...  and proceed as described above.  
 

 
 

Step 2 – Alternative 2: Edit the format table  
Instead of formatting each single tier step by step you can also edit the whole format table at once. 
Choose Format > Edit format table... . You are given the following dialog: 
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The list on top shows you all elements of the transcription that are formatable. Choose the element that 
you would like to edit and proceed as in step 1. The elements “(EMPTY)“ and “(EMPTY-EDITOR)“ refer to 
empty events. 
 
 

Step 3 – Save the format table 
Since the format is not an integral part of the transcription, you have to save it to a separate file. Choose 
Format > Save format table as...  to do this. (As a format table file also has the suffix “.xml” it is advisable 
to choose a name that reveals as well the partitur it belongs to as the fact that it is a format table.) 
 

 
 
 

Step 4 – Open a format table 
If you now reopen the transcription, it will at first be given the default format. To return to your individual 
format, choose Format > Open format table... and the format table saved in step 3 will be applied to the 
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transcription. 
 
Edit more than one format table for one transcription if you would like to optimize the formatting of differ-
ent output methods. 
 
 
3. Output a transcription 
The editor has three methods for outputting partiturs: 
 

1. Print: The partitur will be sent directly to a printer. Use this method if you only want a printout of the 
partitur. On a Macintosh this method can also be used to directly create a PDF version of the parti-
tur. 

2. RTF visualization: The partitur will be exported to a RTF document. This can then be opened by 
most word processors (MS Word in particular) and be further edited there (e. g. add page numbers 
or headers and footers). 

3. HTML visualization: The partitur will be exported to a HTML document. This can then be opened by 
any Internet Browser (Internet Explorer, Netscape Navigator etc.). 

4. SVG visualization: SVG means “Scalable Vector Graphics” and is an XML-based solution for two-
dimensional vector graphics. It's ideal for charts on web pages and as a free, well-documented re-
placement technology for Macromedia Flash. Furthermore SVG files are probably the best solution 
for embedding partiturs as pictures into printed publications. 

 

Setting partitur parameters 
Independently of the actual output method you choose, you can set certain parameters for the output via 
File > Partitur parameters… . 
 
 

Setting up the page 
If you want to output your partitur to a printer or an RTF document, you need to set up the page via 
File > Page setup. (The operating system will give you a dialog to edit the page setup.) Close the dialog 
by clicking on OK. The chosen settings are now retained for printing as well as for RTF visulization. 
 
 

Print a transcription 
To send a partitur to a printer, choose File > Print… . You will be shown the system’s own print dialog. 
(On Mac OS X you can use the Preview button to get a PDF version.) 
 
 

Visualize a transcription as a RTF document 
A word of caution: RTF is a “standard” from Microsoft which is intended to guarantee a loss-free ex-
change of MS Word documents between different versions of the MS Word software. Unfortunately, it 
does not quite work in that way. Different versions of MS Word will render one and the same RTF docu-
ment in different ways. The RTF documents exported from the Partitur Editor will work best with MS Word 
2000 under MS Windows. Other constellations may yield unsatisfactory results. If that is the case, use the 
print method or the HTML visualization instead. 
 
In order to visualize a transcription to RTF, you can start by setting some parameters via the “RTF” tab 
under File > Partitur parameters… . Then choose File > Visualize > RTF partiture… . You will be 
prompted to provide a name for the file. The exported file can then be opened with MS Word: 
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Visualize a transcription as a HTML document 
Another word of caution: HTML is a much more reliable standard than RTF. However, different browsers 
may still render the same HTML document in slightly different manners. Make sure to use a sufficiently 
recent version of your browser in order to minimize these differences. (so far no problems with Internet 
Explorer 6.0 nor with Netscape Navigator 6.1 under MS Windows; under Macintosh we recommend Sa-
fari, Netscape 7.0. or Mozilla). 
 
HTML export is especially useful if you have linked your transcript to audio, video or image files. The 
browser will render these links as hyperlinks and play or show the linked files, provided that it has the 
appropriate plug-ins installed. 
 
In order to visualize a transcription as HTML, you can start by setting some parameters via the “HTML” 
tab under File > Partitur parameters…. Then choose File > Visualize > HTML partiture… . You will be 
prompted to provide a filename for the file and to choose whether the output should have frames or not:  
 

 
 
Chose “No frames“ in case your transcription does not contain any links or if you want your browser to 
open the linked files in a separate window. Choose “Frames” if you want the browser to open the linked 
files in the same window as the transcription (but in a separate frame).  
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Close the dialog by clicking on OK. The exported file can then be opened with an internet browser: 
 

 
 

Hint: Reexport HTML files / Direct sending to browser 

The option „Reexport HTML“ sends the latest version of the transcription directly to the last used HTML 
file. For the “reexport” choose File > Visualize > Reexport HTML. After clicking the Refresh button of your 
browser the new HTML version of the transcription will be loaded. 
 
An even easier alternative is the command File > Visualize > Send HTM partiture to Browser which is 
accessable via the toolbar, too. It sends the latest version of the transcription directly to your browser.  
 

Visualize a section of the transcription to RTF or HTML file 

Frequently, one does not want to visualize the transcription as a whole but only a part of it.  
 

 
 
For instance, in order to visualize only the verbal tiers of this transcription without the German translations 
between two given timeline items of the example transcription used above, follow these instructions: 
 
Select the first translation tier by clicking on the tier label and choose Tier > Hide tier. Proceed likewise 
with the second translation tier and the non verbal tier. (In order to undo these steps later on, choose 
Tier > Show all tiers.) Select the section of the transcription which you’d like to export by clicking on the 
first corresponding time line label and dragging the mouse up to the last time line lable you are interested 
in: 
 

 
 
In order to export the selected section choose Edit > Selection > Selection to RTF... or Edit > Selec-
tion > Selection to HTML... .  
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Visualize a transcription as SVG files 
Using the SVG visualization the Partitur Editor generates a SVG file for each partitur area created by line 
breaks. The SVG files are saved in an automaticly generated folder and are linked by a superordinated 
HTML file which can be opened with any browser that supports the SVG format. 
 
In order to visualize a transcription as SVG files, you can start by setting some parameters via the “SVG” 
tab under File > Partitur parameters…. Set a pixel width and scale factor that serves your purpose. Then 
choose File > Visualize > SVG… . You will be prompted to provide a subdirectory, a filename for the su-
perordinated HTML file and a basic filename for the set of SVG files: 
 

 
 
With the settings chosen above the Partitur Editor generates the following objects: 
 

 

 

 

Subdirectory for SVG files 

Filename 

Base filename 

 
 
4. A final remark 
This “short introduction“ to the EXMARaLDA Partitur Editor is really short, maybe too short. There is 
much more documentation of the software itself and of the underlying EXMARaLDA system in German. If 
you do not happen to get along with the “Handbuch”  (manual) but have questions that this document 
does not answer, please don’t hesitate to subscribe to the EXMARaLDA mailing list (http://www.rrz.uni-
hamburg.de/exmaralda/) and ask your question(s) there. 
 
 

 16

http://www.rrz.uni-hamburg.de/exmaralda/
http://www.rrz.uni-hamburg.de/exmaralda/


A short introduction to the EXMARaLDA Partitur Editor  Thomas Schmidt 
 

BIBLIOGRAPHY 
 
All digital versions of the following publications are available via the extensive bibliography on the EX-
MARaLDA website http://www.rrz.uni-hamburg.de/exmaralda/. 
 
Bird, Steven / Simons, Gary (2002):  Seven Dimensions of Portability for Language Documentation 

and Description. In: Language 79, 557-582. 

Edwards, Jane / Lampert, Martin (Hrsg.) (1992):  Talking Data - Transcription and Coding in Discourse 
Research. Hillsdale: Erlbaum. 

Edwards, Jane (1992):  Principles and Contrasting Systems of Discourse Transcription. In: Edwards / 
Lampert (1992), 3-31. 

Ehlich, Konrad (1992):  HIAT – a Transcription System for Discourse Data. In: Edwards / Lampert 
(1992), 123-148. 

Schmidt, Thomas (2004):  Transcribing and annotating spoken language with EXMARaLDA In: Pro-
ceedings of the LREC-Workshop on XML based richly annotated corpora, Lisbon 2004. Paris: EL-
RA. [digital version available]

Schmidt, Thomas (2004):  EXMARaLDA – ein System zur computergestützten Diskurstranskription. In: 
Mehler, Alexander / Lobin, Henning (Hrsg.) (2004): Automatische Textanalyse. Systeme und Me-
thoden zur Annotation und Analyse natürlichsprachlicher Texte. Wiesbaden: Verlag für Sozialwis-
senschaften, 203-218. 

Schmidt, Thomas (2003):  Visualising Linguistic Annotation as Interlinear Text. Arbeiten zur Mehrspra-
chigkeit, Serie B (46). Hamburg. [digital version available] 

Schmidt, Thomas (2002b):  Gesprächstranskription auf dem Computer: das System EXMARaLDA. In: 
Gesprächsforschung 3, 1-23. [digital version available] 

Schmidt, Thomas (2002a):  EXMARaLDA - ein System zur Diskurstranskription auf dem Computer. 
Arbeiten zur Mehrsprachigkeit, Serie B (34). Hamburg. [digital version available] 

Schmidt, Thomas (2001):  The transcription system EXMARaLDA: An application of the annotation 
graph formalism as the Basis of a Database of Multilingual Spoken Discourse.In: Bird et al. (2001), 
219-227. [digital version available] 

 

 17

http://www.rrz.uni-hamburg.de/exmaralda/


A short introduction to the EXMARaLDA Partitur Editor  Thomas Schmidt 
 

SOME KEYBOARD SHORTCUTS 
 
The marking of keyboards differs from manufacturer to manufacturer. For the following shortcuts  
 
  

Strg  ≙  Ctrl  ≙  ⌘  . 
 
 

 

Menu: Shortcut: Function: 

„File“: 
 

Strg + N  
Strg + O  
Strg + S  
Strg + P  
Strg + R  
Strg + H  
Strg + Shift + H 
 

 

= New 
= Open 
= Save 
= Print 
= Export RTF partiture… 
= Export HTML partiture… 
= Send HTML partiture to browser 

„Edit“: 
 

Strg + C  
Strg + V  
Strg + X  
 

 

= Copy 
= Paste 
= Cut 

„Tier“: 
 

Strg + A 
Strg +  I  
Strg +    
Strg + Alt + H 
 

 

= Add tier 
= Insert tier 
= Move tier upwards 
= Hide tier 

„Event“: 
 

Strg + D 
Strg + 1  
Strg + 2  
Strg + 3  
Strg + Shift + R  
Strg + Shift + L  
Strg + Shift +   
Strg + Shift +   
Strg + Alt +   
Strg + Alt +   
Strg +   
Strg +   
Strg + Enter  
 

 

= Delete event 
= Merge events 
= Split event 
= Double split event 
= Shift characters to the right 
= Shift characters to the left 
= Extend event to the right 
= Extend event to the left 
= Shrink event on the right 
= Shrink event on the left 
= Move event to the right 
= Move event to the left 
= Edit event properties 

„Format“: 
 

Strg + F  
Strg + Shift + S  
 

 

= Format tier 
= Save format table 

Miscellaneous: 
 

Strg + Pos1  
Strg + End  
 

 

= Jump to start (of the transcription) 
= Jump to end (of the transcription) 
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