How to get started

Last updated: 29-10-2010

This document explains how to install the EXMARaLDA tools and how to use the
EXMARaLDA demo corpus to get a first impression of the EXMARaLDA system.
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1. Installation of the tools

Download

You download the EXMARaLDA tools from www.exmaralda.org/en_downloads.html. The
versions you find there are the most recent releases. Previews of upcoming versions can be found
at www.exmaralda.org/previews.html.

Which and how many files you download depends on your operating system:

= Windows: one installation file which contains all EXMARaLDA tools

= Macintosh: four disk images each of which contains one EXMARaLDA tool
= Linux: one gnuzipped tarball containing all EXMARaLDA tools

Java Runtime

In order for the tools to work, your computer needs a Java Runtime Environment (JRE). On
Macintosh, a JRE is preinstalled. On Windows or Linux, you can find out whether a JRE is
installed by typing "java -version™ in a terminal window.

v CAWINDOWSAsystem32\cmd.exe

Microsoft Windows HP [Version 5.1.26001
(C>» Copyright 1985-2881 Microsoft Corp.

in>java —wversion

java version "1 .6.8_11"
Java(TH> S8E Runtime Environment (build 1.6.8_11-hB3>
ava HotSpot<TM> Client UM <build 11.8-bhl6,. mixed mode. sharing)

(RN

If no JRE s installed, you can freely download the newest JRE from Sun at
http://java.com/en/download/manual.jsp. Please note that some Linux distributions come with a
preinstalled JRE which is not Sun's JRE. EXMARaLDA does not work well with these
preinstalled JREs. Replace them with the most recent Sun JRE.

Installation

Once you've downloaded the files appropriate for your system, installation should be

straightforward:

= Windows: double click "setup.exe" and follow the instructions

= Macintosh: mount the disk images and drag the included application file to some appropriate
place on your system

= Linux: unzip the tarball to some appropriate place on your system



2. Demo corpus

A good way to get a first impression of the EXMARaLDA system is to have a look at the
EXMARaLDA demo corpus at http://www.exmaralda.org/corpora/en_demokorpus.html.

EXMARaLDA

Downloads

< Salnco EXMARaLDA Demo Corpus

= Corpus Manager
= EXAKT
= Help & Documentation Browse demo corpus Download demo corpus (ZIP-file, 39MB

Corpora The EXMARaLDA demo corpus is & small corpus with which you can fry out the functionality of the EXMARaLDA system.
= Demonstration
- SFB 538 Gesprachstyp Nacherzahlung
= Other ect- MARAl DA D Transcription Rudi

profect-name ‘EX,\_'"RL““ Dem EXMAR;:_DA: [Transcription] [Set - Ce tlest pas vral
B Ry FURITCL ol Visualisation: [Partiture] [RTF] [Pl ‘ ®a Cexest gas yrei
W cription-name  Pear Story Export: [TEI] [AG] [EAF] [Praat] [C ((1,5s))then | just ﬂschml and | sl 8 = R

ublications 1,55 - dowi bin ke i Seils g @ 22

((aspire

Transkribent Annette Schnieder 3 S
Linguistic Annotation Wiki The demo corpus contains metadatafor Al data are available in several franscription Transcriptions are linked to the audio The dema corpus is multilingual (English,
Contact communications and speakers and presentation formats German, Turkish, French, Spanish)

The demo corpus coniains the following recordings and transcriptions:

i e
J ] Monty Python: My Theory - An English iranscription of Miss Elk presenting her iheory on the brontosaurus (Any ressemblance with real
= linguists is purely coincidential)
Paul McCariney: Interview - an English transcription of an interview with young. ambitionless Paul McCartney
Pear Story - An English transcription of a retelling of Wallace Chafe's Pear Story

Deutsche
Forschungsgemeinschaft
DFG Rudi Véller: Wutausbruch - a legendary fit of rage by the manager of the German national football team

Helge Schneider Tropisteinhohle - a short audio play by the German artist Helge Schneider which contains many speaker overlaps
Hubert Fichte: Interview - an interview which was conducted by the German writer Hubert Fichte in Hamburg's St Pauli district

UH Helge Schneider: Arbeitsamt - another short audio play by Helge Schneider

m Studio Braun® English Translator - a telephone conversation between an unsuspecting seller of erasers and members of Studio Braun
Unbverthit Hamburg Deutsche Bahn' Rossau - a telephone conversation between a man from saxony and the Deutsche Bahn railway timetable computer

Studio Braun: Forum Waffenrecht - another telephone conversation from Studio Braun

Hart aber fair - an excerpt from the TV talk show 'Hart aber fair'

Anne Will: Halbes Wahirecht - an excerpt from the TV talkshow ‘Anne Will'

DER IOISCHUNG | DEE LDMRE 1 DER BIDUNG.

SOURCEFORGE.NET*

Serif Issk. Expertenauskunft - a Turkish transcription of a telephone conversation between an expert on social matters and a somewhat
confused caller

You can start by browsing the online version of the corpus — there are transcription examples in
several languages (see also "How to use an EXMARaLDA corpus"”). You can then also download
a ZIP archive of the demo corpus. In the following three sections, we assume that you
downloaded the demo corpus and unpacked it onto your system. The unpacked folder structure
should look something like this:



3. Partitur Editor

To get a first impression of the Partitur-Editor, start it...

= ...on Windows by selecting the appropriate entry in the start menu or by double clicking the
symbol on your desktop...

= ... on Macintosh by double clicking the application symbol...

= ...on Linux by double clicking "partitureditor.sh” or by calling this shell script from a
terminal window (you may have to make the file executable before the first start)...

... and open a basic transcription file from the demo corpus via File > Open. Basic transcriptions
can be found in all directories on the first level (i.e. 'Arbeitsamt’ , EnglishTranslator' etc.). They
have the ending ".exb". For example, you could open "MyTheory/MyTheory.exb™ in the Partitur-
Editor:

# EXMARaLDA Partitur-Editor 1.5 [C2\DATEN\EXMARaLDA_DemoKorpus\MyTheory\MyTheory.exb]

Flle Edit View Transcripton Tier Event Timelne Format Help
: P S (@ : . D =i 3 = 4 omm -+
:Dteﬁm @\e) &.\4 :rki?cﬁ- '-'-'::t:&--:::*i E:*:—?_‘gé gl‘i- I%SI:I
Good evening. T’
@ 0185 [ 0.44 00:02.33
................. T Ly e B B B .y BB
00:00 0ot o002 o003 0004 00:08 00:06 ooo?
< Ll
[ msmet ] [ Blawerineva | O b o 0] n | = °
0 [00:00.0] 1 [00:0] 2 [00:01.5) 3[O0023] |4 [00031] 5 [0:14.1] 600180 | 7[00
PRE [v] Good evening. | have with me « tonight « = Ann Elk Mistress Ann Elk, . YoLU
ELK [v]  « Missl
[nn] (laughter, 1,3s)) (= r - {faughter)} | fimusic, pocasional laughter, 115}
PRE [k]
ELK [K]
< >
‘ Dor [
[09:37:26] Partitur-Editor started

To continue from here, have a look at one of the following documents (available from the
help section of the EXMARaLDA website):

= Partitur-Editor video tutorial

= Document “How to Make a Transcription From a Digital Recording”

=  Documents “How to use the Partitur-Editor with written data” and “How to import text
transcriptions”

Partitur-Editor Manual



4. Corpus Manager

To get a first impression of the Corpus Manager, start it (see above) and open the corpus file of
the demo corpus via File > Open Document. The corpus file is in the top level directory and has
the name "EXMARaLDA_DemoKorpus.coma. After opening it, switch to the "Data" tab and
browse through the lists on the left and right side to see meta-data about communications and
speakers.

# EXMARaLDA Coma | EXMARaLDA_DemoKorpus.coma | Corpus: DEMO-KORPUS

File View Analysis Maintenance Help

\(/ Corpus Data | {=} Basket (0) % Settings

Filter : Search 4 Filter

4
13 Communications 28 Speaker

Communication = = . || 5 | sigle | Beruf
¢ communication Monty Python: My
S | Mame Gesprachstyp ERW  Verfahrenstechniker
Theow [ Fichte Schriftsteler
Rudi Véller: Wutausbruch Fernsehinterview !
Helge Schneider: Arbeitsamt Telefonisches Arbeitsv. .. Description :Communicationlw KLA Arbeitslos
Hubert Fichte: Interview Leitfadeninterview G schst TV inteni an Teamchef der Fullbalinati...
Helge Schneider: Tropfsteinhéhle  Alltagsgespréch EEPFE_E styp ==Y . \'"_" STPFUDU’HEI'SF seit 1970
Studio Braun: English Translator Telefongesprach Transkribent Thomas Schmidt g:l;_r :";Bdﬁfbt:"'; szer:‘a:‘]o....
2 ‘achnanges T Tur Arbel...
Deutsche Bahn: Rossau Telefongesprach Transkription erstellt im Januar 2009 e oo rarﬁmierer
Studio Braun: Forum Waffenrecht  Telefongesprach folder MyTheo g
Ségoléne Royal: Débat Fernsehdebatte . v v L DD‘mEtSdTT -
Fernando Savater: Hermandad Fernsehinterview project-name EXMARaLDA DemokKorpus H™ Hauptschulletrer
Paul McCartney: Interview Radicinterview transcription-convention HIAT EFS I:‘Iaurer
Serif Issi: Expertenauskunft Telefongespréach B L
transcription-name Pear Stol
Pear Story Macherzahlung i Y a Sbeuerhdﬂqeh\lﬁn
onty b on: iy Ty | |/ T
No Location = SR Paitierin
__________________________________________| NS Staatsprésident
No Languages‘%“ FP TV-Moderator
N A 1Y Moieatien
Setting F5 Schriftsteller
LR Radiomoderator
Description (null)[ < INT Radiomoderator
PMC Musiker
:# 3 Recordings‘%‘ MoD EXDEI’tE.ﬁ_'IF sozisle Fragen
. ANR Rentnerin
Recording: MyTheory.flv= X 277
- inaVZ ¥ FET]
Description (Recording) @ PRE TV person
File: MyTheory.flv [ ek Theorist

Recording: MyTheory.mp3=
Description lRecording}M

EI] S[s]/%|[+]- a[e]

+=]a

To continue from here, have a look at one of the following documents (available from the
help section of the EXMARaLDA website):

= Corpus Manager Manual
= Document “How to Create a Corpus From Transcriptions”



5. EXAKT

To get a first impression of the query tool EXAKT, start it (see above) and open the corpus file of
the demo corpus via File > Open Corpus. The corpus file is in the top level directory and has the
name "EXMARaLDA _DemoKorpus.coma". Opening the corpus may take some seconds because
EXAKT first creates an index, then a wordlist. The opened corpus and the wordlist will be

displayed in the section titled "Corpora".

Corpora

DEMO-KORPUS
C:\DATE...LDA_Demokorpus.coma
13 transcriptions
620 segment chains

Word lists

Word list for DEMO-KORPUS
2521 types 7870 tokens

A new concordance will be opened automatically. Make a test query for the word 'the' by entering
the expression \bthe\b in the text field beside the Search: button and hit enter to carry out the

query:

%] EXMARALDA EXAKT 1.0 [[i=1(E3]

Fle Edit View Concordance Columns Rows RegEx Help
: = e
‘e b e B
Corpora 4| DEMO-KORPUS (49 results) |
DEMO-KORPUS
CHDATE. .LDA_Demok RegEx (1) T BEry
égum‘z""s . # S | Communication Speaker Left Context Match Right Context g{i ]
1 Studio Braun: English Tra._ |HM ((0,35)) I'd/ I'd | want to speak with the German/ with the German inti eh people wh &
2 Studio Braun: English Tra._ |HM ) 'd/Td | want to speak with the German/ with the German int eh people who is intarasting in @’“’ ]
3 Studio Braun: English Tra._ |HM h the German int/ eh people who is interesting in the gums.
4 Studio Braun: English Tra._[TT lam the translator of Mr Bernd Schwanmeister. He i @
= 5 Studio Braun: English Tra._[TT ((Einatmen)} Aand he is calling because of the &h erasure gums. A
| Bane; | 6 Studio Braun: English Tra._[TT am a translation (eh) tr/ translation service of the telephone company. |E
. 7 Studio Braun: English Tra._[TT (Hello), | am in the line all the time. Now eh it's a service from
Ward lists 8 Studio Braun: English Tra._[TT (Hello), 1 am in the line all the time. Now eh its a service from (the) eeh Er m I
Word list for DEMO-KORPUS 9 Studio Braun: English Tra._[TT he line all the time. Now eh it's a service from the ) eeh English telephone company. Types:
2521 types 7870 tokens 10 Studio Braun: English Tra..JTT (S0} he is asking what's about the eraser gums? 1
11 Studio Braun: English Tra_[TT Yeah, yiyou can. He isin the line Tokens:
Studio Braun: English Tra_. TT ‘You can get them in Hamburg, erasure gums. 49
Concordances 13 Studio Braun: English Tra._[TT He wants you to stop ((0,3s)) the English tf translation and to talk eh dif direct ~ Selected: .
14 Paul McCartney: Interview |\NT u in this entire tour_» » ((breathes in)) Before| the |word "Beatles™ ever came into your life, » » 3 & - 8 (1)
. : T ——= = = ot 5 T = —— Bfrime:
DEMO-KORPUS. < | > 0.31s
49 tokens - e
1 types You can get them in Hamburg, the erasure pums.
avw
[> | m | Partinr
@ [01:23.0] [01:31.9]
- N - -~
BS [en] What does figurative erasers actually mean? =
TT[v] [P gums. Well, what does it mean that they are fi gurish?
[nn] v
< | >
@ Partitur (JList (O HTML

To continue from here, read the EXAKT manual available from the help section of the
EXMARaLDA website.



